(<)
BERUKER
( ><

SetPre for MRI

Gradient Amplifier Software
User Manual

Version 001




The information in this manual may be altered without notice.

BRUKER accepts no responsibility for actions taken as a result of use of this ma-
nual. BRUKER accepts no liability for any mistakes contained in the manual, lead-
ing to coincidental damage, whether during installation or operation of the instru-
ment. Unauthorised reproduction of manual contents, without written permission
from the publishers, or translation into an other language, either the entire manual
or a part of it, is forbidden.

This manual describes the units as they are at the date of printing. On request, the
manufacturer shall supply circuit diagrams, lists of components, descriptions, cali-
brating instructions and any other information for use by qualified personnel of the
user, in charge of repairing the parts of the unit which have been stated by the
manufacturer to be "repairable". Such supply shall in no event constitute permis-
sion to modify or repair the units or approval of the same.

All rights reserved for the units, circuits, processes and appellations mentioned
herein.

This unit is not designed for any type of use which is not specifically described in
this manual. Such use may be hazardous.

This manual was written by
BROSSEAU Vincent
© November 17, 2006: Bruker Biospin SA
Wissembourg, France

P/N: 231806
DWG-Nr: Z4D10196



Contents

(0207 11 0= ¢ 1 £ iii

1 Preemphasis tool for the gradient amplifiers ...... 5
1.1 What is SetPre used for ? .....covviiiiiiiiiii 5
1.2 Starting SetPre ... 6
1.3 How SetPre Works ... 7
2 The Graphical User Interface ............cccvueeunennn.n. 9
2.1 The common CONtrolS ..., 9
Device identification ... 9

Channel control ... 9

Preemphasis sliders ... 10

Read/Write parameters files ..........cccoooiiiiiiiiiininnee, 11

The ToOIbar ...coeie e 12

GradPar and RampPar tools .........cccccovviiiiiiiiiiiineen, 13

Amplifier and Preemphasis activation ............................ 13

Reset protection ..., 13

2.2 The amplifier-dependant controls ...t 14
Offset (all amplifiers except BGU2) .......ccoooeiiiiiiiinnnannn. 14

Loop parameters (all amplifiers except BGU2) .............. 14

Amplifier gain (Master Unitonly) ...........coooiiiiiiiiiinnns 15

Rate temperature (all amplifiers except GREATS) .......... 15

Other controls (from the "Options" menu) ...................... 15

| Lo 17 ] = 17

SetPre for MRI Version 001 QBTSSR iii



Contents

iv QBTSSR SetPre for MRI Version 001



Preemphasis tool for
the gradient
amplifiers

What is SetPre used for ? 1.1

For electronic reasons, the gradient signal generated by the GCU is never exactly
as expected (see Figure 1.1).

Figure 1.1. GCU signal

expected Measured

That's why it's necessary to create another signal which can be added with the
GCU signal, in order to correct the distortion. This additional signal is the preem-
phasis signal (see Figure 1.2).

Figure 1.2. Preemphasis correction

T |

Preemphasis r

The SetPre program is the tool that must be used to set this preemphasis signal
(the red curve on Figure 1.2).
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Preemphasis tool for the gradient amplifiers

Starting SetPre

1.2

[I% Mo preemphasiz amplifier nor GAB detected, l Unknewn connected amplifier!
= Device may not be configured yet, do 'of' first, =

To start SetPre, use the item menu "Tools" = "Adjust Preemphasis Values", in
the ParaVision "Spectrometer Control Tool" window.

The GUI communicates with a server-program which controls the hardware (the
gradient amplifier) and handles the parameters files. If the GUI does not manage
to connect to this server (for example because of network troubles), the message
shown on Figure 1.3 may be displayed.

Figure 1.3. Server connection error

e Can not connect SetPre server |

| Close || Details... |

L

If the server connection succeeds, then the server gets the current hardware con-
figuration. If a suitable device is detected (a GAB, or a Master Unit, or any preem-
phasis amplifier), its associated graphical user interface is displayed (see "The
Graphical User Interface” on page 9). In the other case, one of the messages
shown on Figure 1.4 may be displayed.

Figure 1.4. Amplifier detection error

| Close || Deatails... | | Close || Details... |
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How SetPre works

How SetPre works 1.3

Even if it's started from ParaVision, SetPre runs in the TOPSPIN program. The
first time you start SetPre, the connected device (GAB, BGU2, GREAT or Master
Unit) is identified and the hardware parameters values are loaded. If you close
SetPre without closing TOPSPIN, and then you start it again, this identification &
loading step is not done again : it's assumed that the hardware configuration has
not changed.

Afterwards, each parameter modification (via the GUI) is never sent to the hard-
ware (this is the "cache mode"), unless you activate the "upload" button in the
SetPre toolbar. Offset auto-adjustment and option items (in the "Options" menu)
are exceptions : in these cases, the hardware is directly updated.

But in the other cases, the hardware updating is controlled by the acquisition mo-
dule.
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The Graphical User
Interface

The common controls 2.1

Device identification 2.1.1

On the upper left corner of the window, you can see which device is connected.
The possible names are : "GAB", "BGU2", "GREAT 1/10", "GREAT 3/10" or "Mas-
ter Unit".

On the lower right corner of the window, the current system status is indicated.

Note : the GAB has no GUI, but the SetPre menu ("File" and "Edit") is available.

Channel control 2.1.2

The default selected channel is always Z (if it's available). But you can select any
other channel in the pull-down list at the top of the window.

The content of this list depends on the current hardware configuration (see the
example of the Master Unit, on Figure 2.1).
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The Graphical User Interface

Figure 2.1. Channel control

SetPre
Master Unit | £ preemphasis '| % ﬂ | Temperature 22°C
10 A ¥ | & alX preemphasis || 3878 |~ oo01 A
Z preemphasis |:_:_:|
Slow base | | o compensation A [¥|]| 7501 0.01
200.0ms ¥ | |z BO compensation H [»]| 4284 |~ o001 |-
Mid base | Time[ms] [« [} |¥]| 1562 |~ ool |-
|200.0ms ¥| Gainxl 4] ] |¥|| 6878 |~ o001 |-
Fast base | Time[ms] |d] B |»|]| 3604 || 001 |a
2000ms v| Ganfxl 4] LI D] 9320 + o001 s
CACHE mode System status : SO40
Device Available channels
GAB none
BGU2 X,Y,Z,XB0,YB0,ZB0,YX,XY,XZ,ZX,Z2Y,YZ
GREAT 1/10 Z
GREAT 3/10 X,Y,Z
Master Unit X,Y,Z,XB0,YBO0,ZB0 (*)

(*) Master Unit constraints :

* X, Y and Z are available only if amplifier X, Y and Z resp. are connected
® XBO available only if amplifier X and amplifier BO are connected

® YBO available only if amplifier Y and amplifier BO are connected

® ZBO0 available only if amplifier Z and amplifier BO are connected

Preemphasis sliders 2.1.3

Preemphasis are generated by the amplifier controller itself.

The preemphasis signal results from the addition of 3 preemphasis curves
(see Figure 2.2).

10 (19) WERSYSTR SetPre for MRI Version 001




The common controls

Figure 2.2. Preemphasis signal
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Each curve is an exponential function defined by its gain and its time constant
(see Figure 2.3).

Figure 2.3. Preemphasis control

gain
time
Slow base | Time [ms] [d4] B M| 7500 v o001 |«
2000ms ¥| Gain[x 4] B [»|| 4284 |~ o001 |«

Time base : "DC", "0.2 ms", "2.0 ms", "20 ms" or "200 ms"

Time : its lower limit is 0 ms, and its upper limit value depends of the selected time
base (ex. : if time base is "200ms", then time max. is 200 ms).

Gain : from -100% to 100%

Read/Write parameters files 2.1.4

In the SetPre "File" menu, you may choose to read or write a parameter file (see
Figure 2.4). You may select the file in a dialog box ("Read from..." or "Write to..."),
or you may use the "default".

In any case, all the parameters file localisation depends on the current system
status : <PVHOME>/exp/stan/nmr/parx/preemp/<SYSTEMSTATUS>.
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The Graphical User Interface

Figure 2.4. File menu

[l Bruker TOPSRIN 1.5.b.2 on neo.bruker.fras nmrsu

File Edit View Spectrometer Processing Analysis Options Window Help

Dad(® e k@8 e o Qw7
228 8 s (ARG CE0 e o e HF oL

Read default
Edit * Read from ...

|Br0wser|PFoIio‘AIias| || sutie B 7| Options »| Write default | &“& &
& 9 fopt/FV4.0 Master Unit |Z preemphasis MEL EGEAEE Write to ... 22°C

|10A v| O auta offser(%] [4] M_ 3878 |~ o001 ‘-[

Slow base Time (ms] |4 » 75.01 v 001 &

2000ms ¥| Gainps |4 | 4281 |~| o001 A|

Mid base | Time [ms] I:li »| 1562 || o001 ‘|

2000ms v| Ganpm [ »| 6878 || 001 A|

Fast base Time [ms] |4 — |»]| 36.04 ¥ 001 A|

2000ms ¥| Gainpe |4 [»]| @320 |~| 001 ‘|

CACHE mode Systern status : $040 ‘

The Toolbar 2.1.5

Parameters

For convenient reason, some parameters may be handled in memory.

store the current parameters in memory (NOT on the disk) :

% - Preemphasis
- offset, impedance and loop parameters (GREATs only)

- amplifier gain (Master Unit only)
recall the stored parameters
exchange the current parameters with those which are stored

undo the modifications (set the initial values)

N9 (D

clear (set to null) the preemphasis gain values

Common
? help : open this user's guide
ﬁ about : open the "about" window (author information)
download the parameters from the hardware

upload the parameters to the hardware
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The common controls

GradPar and RampPar tools 2.1.6

From the "Edit" menu (see Figure 2.5), you can start the other tools "GradPar"
(the gradient parameters GUI) and RampPar (the ramp parameters GUI).

Figure 2.5. Edit menu

SetPre

File  »|

Edit » Gradient parameters [gradpar]
Options ¥ Ramp parameters [ramppar]

Rate to measure temperature

Gradient parameters and ramp parameters are stored where the other parame-
ters (offsets, loop parameters, preemphasis, ...etc) are stored, but the gradient
parameters are also stored in the file <PVHOME>/conf/instr/gradient_calib.

Amplifier and Preemphasis activation 2.1.7

From the "Options" menu (see Figure 2.6), you can activate/deactivate each am-
plifier and each preemphasis correction. These options are available only for
channels X, Y and Z.

Figure 2.6. Options menu

SetPre
| File »
Edit »

Options » / Preemphasis bypassed

v Amplifier enabled
Offset adjustiment

Reset protection

Impedance&loop editing

Reset protection 2.1.8

From the "Options" menu (see Figure 2.6), you can reset the amplifier protection.
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The Graphical User Interface

The amplifier-dependant controls 2.2

Offset (all amplifiers except BGU2) 2.2.1

The preemphasis offset may be adjusted (from -100% to 100%) thanks to the spe-
cific slider control (see Figure 2.7).

Figure 2.7. Offset adjustment

| Oamo offser(s |4 | [»| 3878 |~ 001 |-

The "Auto" option may be activated to start the offset auto-adjustment. In this
case, when the auto-adjustment is finished, the offset value is updated and the
slider is adjusted too.

Those features are channel-dependant (each channel - X, Y and Z - has its own
offset). It's possible to start the offset auto-adjustment of all the channels simulta-
neously, thanks to the menu item "Offset adjustment” in the "Options" menu (see
Figure 2.6)

Loop parameters (all amplifiers except BGU2) 2.2.2

You can access to the loop parameters from the item menu "Impedance&loop
editing”, in the "Options" menu (see Figure 2.6). The NMR administration pass-
word is required (see Figure 2.8).

Figure 2.8. NMR administration password

Please enter the MMR administration
password:

[ |

If the access is granted, specific sliders will be displayed. Use them to change the
impedance value ("Low" or "High") and the capacitors and resistors values (from
0% to 100%, see Figure 2.9).

Figure 2.9. Loop parameters

Impedance | Resistors [%] | 4] B [»]| 333 |+ o1 |-
High ~ | capacitors [%]| 4] [ [¥]| 407 |+ o1 |-
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The amplifier-dependant controls

Amplifier gain (Master Unit only) 2.2.3

As you can see on Figure 2.10, you can select from 10A to 40A (or 60A, depen-
ding on which type of amplifier is connected).

Figure 2.10. Amplifier gain

SetPre

Master Unit |Z preemphasis B

104 v| O are  Offset[%] |<

B0 A SE Time [ms] |4

504 = ———————————
40 A, - Gain [%] _‘

A0A e Time [ms] |4 .

2004 r

10 A - Gain [%] I(

Fast hase Time [ms] I( ._

Rate temperature (all amplifiers except GREATSs) 2.2.4

The device internal temperature is displayed on the upper right corner of the Set-
Pre window. It's value is refreshed every X seconds, where X may be set from the
"Rate to measure temperature” item in the "Options" menu (see Figure 2.11).

Figure 2.11. Rate to measure temperature

p X
Rate to measure temperaturea[s]|S
(0] Cancel

Other controls (from the "Options" menu) 2.2.5

® BO compensation (BGU2 and Master Unit only)
® Gradient generation (BGUZ2 only)

SetPre for MRI Version 001 QBTSSR 15 (19)



The Graphical User Interface
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Notes
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